Ref Rows not showing up on Inline form?

behavior
(David Hopkins) #1

So i have several ref_rows that display on my Inline form…

two of them in this example:

  1. Related Incident Reports
  2. Related Transactions

Both are configured (display wise) exactly the same. However, when I click ADD to add a new record to the Bookings table, the Related Incident Reports table displays in the form but the Related Transactions does not. (I don’t want either to show at that time, because the record is not ready for the relating info yet.)

I know this isnt much to go on… but any insight would be greatly appreciated.

Thanks in advance.

(David Hopkins) #2

#open

(Tony Fader) #3

Hi @David_Hopkins. Do you have the “part of” relationship set for your ref columns? When “part of” is set, it will create a nested form when adding new parent records.

http://www.appsheet.com/samples/How-to-use-nested-forms?appGuidString=d6cfb54e-80c3-461f-971f-8d65a955759b

(David Hopkins) #4

Way to go Tony… Thank You … that was it…

Ok… so perhaps you can help me with the logic here as well then…

I would like the Incident Reports records deleted if someone deletes a booking. I was using the “Is Part Of” for that purpose. Would you know of a better way?

(Tony Fader) #5

How about creating a slice of your parent table that doesn’t include the referenced rows columns, then creating a form on that slice? That way, you can keep the part-of relationship, but not show the nested forms when adding a new row.

(David Hopkins) #6

I tried that… but the main action to create the form for a booking (the + button) ends up on a record view rather than on the primary Booking view. that’s a trick i’ve tried to conquer before but have been unable to.

(Tony Fader) #7

You could also use a Show If formula in your list column, then.

If you want to hide the column only when adding a new row, you can use the show-if formula IN([Key Column], TableName[KeyColumn]).

Details about why that works in this thread: Hi All, How to hide a column in the Form vi...

Make sure that " UX > Options > Apply show-if constraints universally" is enabled.

1 Like
(David Hopkins) #8

oh man… i’ve been looking for something like that… i had been trying ISBLANK([key]) and the like.

Thanks again sir… very helpful!~

1 Like