So I'm still in the development stages for 4 ...

(Joshua Giles) #1

So I’m still in the development stages for 4 separate apps that all pull from the same excel file on Box. 2 of the apps allow a user to be logged into a GMail account while the other 2 require me to be logged into a Box account that has been given access to that excel document. I want all 4 apps to be able to be accessed by any logged in account.

I have all the same security settings set on the Security Tab under “Require Sign-In” for all 4. Which is:

Require User Authentication? ON Authentication provider: Any Provider Allow all signed-in users: OFF

And I’ve approved this specific Gmail user for all 4 of them.

The error that I receive on the 2 that aren’t working says, “Unable to fetch app definition: Error:User ‘553644’ does not have a valid ‘box’ account/n”

Any ideas? It’s the strangest thing because I’ve created all 4 using the exact same methods :frowning:

(Aleksi Alkio) #2

Have you checked that all apps have correct users in the whitelist?

(Joshua Giles) #3

@Aleksi_Alkio Yes, they all have the same GMail users in the whitelist

(Aleksi Alkio) #4

When you open and close apps while changing accounts etc. sometimes the browser is not able to “follow” all of this. Clearing the browser’s cache sometimes helps.

(Aleksi Alkio) #5

Is it possible that you are using older version in those two apps?

(Joshua Giles) #6

I made them all in the same day and they’re all linked to the same excel document.

(Joshua Giles) #7

It’s baffling…

(Aleksi Alkio) #8

If all your users are using gmail account, what happens if you change the Authentication provider to Google?

(Joshua Giles) #9

It still has the same problem when switched to Google as the authentication provider.

What’s interesting to me is if I turn off the User Authentication if gives me an error saying, the data table “needs to be accessed with the end-user’s auth.” which makes me think the setting is different in the referenced sheet rather than the security setting.

(Joshua Giles) #10

So cool story, turning on and off that security setting requiring the user be logged in multiple times fixed one of the apps. Let me see if the same trick works with the other.

(Aleksi Alkio) #11

Have you tried to clean the cache?

(Joshua Giles) #12

I didn’t know that was a thing. How do you do it and what does it do?

(Aleksi Alkio) #13

When you open and close apps while changing accounts etc. sometimes the browser is not able to “follow” all of this. Clearing the browser’s cache sometimes helps.

(Aleksi Alkio) #14

Have you tried to clean the cache?

(Joshua Giles) #15

I didn’t know that was a thing. How do you do it and what does it do?

(Aleksi Alkio) #16

Have you checked that all apps have correct users in the whitelist?

(Joshua Giles) #17

@Aleksi_Alkio Yes, they all have the same GMail users in the whitelist

(Aleksi Alkio) #18

Is it possible that you are using older version in those two apps?

(Joshua Giles) #19

I made them all in the same day and they’re all linked to the same excel document.

(Joshua Giles) #20

It’s baffling…