Why there is no one care for my problem. is it because i didn't deploy it yet?

Really disappoint with this.
i’m trying to asking so many times. and try to find the problem.
But no one from appsheet staff care about this.
Is it because i’m still free user so no need to put attention to fix this issue?
even to answer what i should do, or what i should check?
speechless…

@Novianto_Djunaedi
Community is receiving around 200 posts each day, and it’s quite possible that it might have got lost from focus. I hope you are not expecting from us to dig down around 25000 posts to discover out what your issue was. So rather than a complaint, a kind remembrance might benefit to all of us. Thnx for your understanding.

Secondly, between the time-frame that you had posted your issue until today, may I ask provided have you tried the search feature to check similar or even identical issue posts and possible solutions?

2 Likes

Well, i’m tried to find out the problem and keep asking for a month, but still can’t find any clue, and no response at all. appsheet was really a great help for us. if it’s working properly. but when i found this problem, i’m waiting for a month without any progress.
So i hope with my post today, it will attract someone to help find out.

The problem is.

  1. Image path is name with some kind of “%” or “storage” or “emulated” some like that. that i believe should be not like that. i need a normal path for run macro on excel.

  2. sometimes, image files dan image path was stored on google drive and goolesheet. and on second. it was suddenly gone.

I already try to find on community about this. but can’t find anything.
i try to find out from google sheet history, and found this

  • List item Novianto Djunaedi
    December 18, 8:14 PM
    Added: “Data_Images/INST111111.REDAMAN OPM FAT.131421.jpg”

  • List item Novianto Djunaedi
    December 18, 8:14 PM
    Deleted: “Data_Images/INST111111.REDAMAN OPM FAT.131421.jpg”

  • List item Novianto Djunaedi
    December 18, 8:17 PM
    Added: “Data_Images/INST111111.REDAMAN OPM FAT.131737.jpg”

  • List item Novianto Djunaedi
    December 18, 8:18 PM
    Deleted: “Data_Images/INST111111.REDAMAN OPM FAT.131737.jpg”

  • List item Novianto Djunaedi
    December 18, 8:32 PM
    Added: “Data_Images/INST111111.REDAMAN OPM FAT.133240.jpg”

  • List item Novianto Djunaedi
    December 18, 8:33 PM
    Deleted: “Data_Images/INST111111.REDAMAN OPM FAT.133240.jpg”

  • List item Novianto Djunaedi
    December 18, 8:36 PM
    Added: “Data_Images/INST111111.REDAMAN OPM FAT.133547.jpg”

  • List item Novianto Djunaedi
    December 18, 8:36 PM
    Deleted: “Data_Images/INST111111.REDAMAN OPM FAT.133547.jpg”

  • List item Novianto Djunaedi
    December 18, 8:51 PM
    Added: “Data_Images/INST111111.REDAMAN OPM FAT.135046.jpg”

  • List item Novianto Djunaedi
    December 18, 8:51 PM
    Replaced: “Data_Images/INST111111.REDAMAN OPM FAT.135046.jpg” with “SO-11111111/INST111111.REDAMAN OPM FAT.135109.jpg”

  • List item Replaced: “FAT.135109.jpg” with “FAT.135201.jpg”, within “SO-11111111/INST111111.REDAMAN OPM FAT.135109.jpg”

i really doesn’t have idea, is it because a bug, a wrong configuration, or a limitation, or anything else.
So please if you can figure out, please help me.
Thanks

And lately, more image column that effected by this problem
before was 8, sometimes can be 16 column. and lately 19 column (all image column) on a row.

Is your issue related to this post?

No.
The system saves some photos in a wrong path and some photos in a correct path.
An example of two photos (1 wrong and 1 correct):
IMBALLI_Files_/29-19COL48.Foto1.120115.jpg WRONG
IMBALLI_Images/29-19COL48.Foto2.120115.jpg CORRECT

@Novianto_Djunaedi
Your file name "Data_Images/INST111111.REDAMAN OPM FAT.135046.jpg" indicates that:
1.) Your table name is > Data
2.) In above table, your Key Column value is > INST111111
3.) Your image column name is > REDAMAN OPM FAT
4.) The number at the end is the unique timestamp

From your list of images, I do understand that all these images are on the same row. For the replaced ones; please ensure that:
1.) You haven’t specified a file location of SO-111111111 to your image column explicitly


2.) You haven’t changed the default path of your app via Info > Properties > App Properties > Default app folder


Have you ever checked these help pages?



And lastly, provided you search the community with the image path keyword, a number of 50+ posts are listed with very similar issues:
https://community.appsheet.com/search?q=image%20path

3 Likes

@Geaimaforni_Service
Your Foto1 column’s TYPE is not an image but set as a FILE and therefore its saved under TableName_Files_ folder by-default. So this is basically a human error, not an AppSheet bug or error.

2 Likes

Dear LeventK,
yes, it’s a human error. Yours. Because they are set as image, otherwise why sometimes it works and sometimes not in the same column? And anyway I obviosuly check before issuing the post.
R.

@Geaimaforni_Service
I’m an AppSheet Partner and Developer since 4 years and I have built around may be over 150 apps, and have never even once experienced that AppSheet is saving images to somewhere else than its designated folder. Your saved folder name in the example, very clearly show that the Foto1 column’s type is, was, has been (or whatever) set as FILE not an IMAGE. But provided you say that it’s my human error, I won’t argue.

1 Like

@Novianto_Djunaedi What is your account ID number and app name if I check it? And from where should I find these image columns?

Hi @Aleksi
My account number is 1058145
App name is “PAG IKR_rev01”

I think it was the different issues.

Thanks LeventK, but seems it is doesn’t what i mean.

  1. The problem started 1 month ago. When the folder still on default. (on Data_Images).
  2. I think maybe it happened because too many image on one folder, so i try to create a folder based on the some column value.
  3. Sorry my english was not really good. But from your response me to check a link. It was a guide to show the image on sheet. But the problem is. The image file on my google drive was also gone…

Here is the screenshot.


And this if i use “Test”
is there something i missing? Thanks

@Novianto_Djunaedi
Provided you pay attention to your screenshots, you had specified a FOLDER LOCATION/PATH for that RADAMAN OPM FAT column. See below:


And you had specified the image location in a way that, it’s reading the value from a column named as [NO SO] and I believe the columns value is a concatenation of a text and a number followed by it. In your expression test screenshot, it’s very much obvious that the value of this [NO SO] column has been malformed because possibly the text value in the concatenating column is empty so only the number part is displayed.


Long story short; you have assigned a column’s value to your folder path which will eventually force appsheet to create separate folders (where the folder names will be the values in [SO NO] column as per your expression) for each image in your table. As per your test screenshot, for the images in Row# 78, 79, 80 and 81, you should have below folders and image files under your app folder and actually there’s nothing wrong here as per your own app settings:

Folder Name File Name Full Image Path
SO-0052960 KeyColumnValue.RADAMAN OPM FAT.xxxxxx.jpg SO-0052960/KeyColumnValue.RADAMAN OPM FAT.xxxxxx.jpg
SO-1231231 KeyColumnValue.RADAMAN OPM FAT.xxxxxx.jpg SO-1231231/KeyColumnValue.RADAMAN OPM FAT.xxxxxx.jpg
SO-1111111 KeyColumnValue.RADAMAN OPM FAT.xxxxxx.jpg SO-1111111/KeyColumnValue.RADAMAN OPM FAT.xxxxxx.jpg
1231111 KeyColumnValue.RADAMAN OPM FAT.xxxxxx.jpg 1231111/KeyColumnValue.RADAMAN OPM FAT.xxxxxx.jpg
2 Likes

Hi @LeventK, Thanks for your response.
Sorry to make confuse. but the problem is not that. that cell that only write number, is because i input the value is only number on that row. (i’m trying to create a trial to find out what is the problem, so i just input any value)
the main problem is.
Some cell that i set for image path. it was suddenly replaced or deleted.
maybe i will try to record screen.

and for the data sheet, if you would mind, please check. here is the link

maybe you will more understand than what i’m trying to explain.

I’m afraid you are not reading my words carefully or I’m completely haven’t been able to grab your issue. Shortly, when you assign a FOLDER PATH to any image, the image will be saved to that folder explicitly rather than the Tablename_Images default subfolder under your app’s main folder. As you have specified a column’s value as a folder path, AppSheet is creating a folder for each row of data with respect to that specified column’s value under your Google Drive root, but no where else.

As you had made this location change, after you have created some images to the default folder (which was Data_Images folder), and the images path are records as i.e. Data_Images/INST111111.REDAMAN OPM FAT.133547.jpg, now that you have changed the location to be the value of [NO SO] column, AppSheet is searching the image under this folder i.e.:
SO-0052960/Data_Images/INST111111.REDAMAN OPM FAT.133547.jpg
This folder path is now completely false and as there isn’t any Data_Images subfolder under that SO-0052960 folder, the image link is broken. There is nothing replaced or deleted therefore I may indeed advise you checking your structure carefully.

1 Like

From what i got, you try telling me about the link is broken. so that’s the reason image was not shown on apps. is that right?

Correct

Well, the problem is not a link broken mate. But the link is gone. I post a new thread with a screenshoot picture. Even on the sheet. The link / path was not there. Sometimes it writed for a second, then disapeared. Or sometimes looks normal. Then suddenly gone.