Why would a DREF not be recognized? The fiel...

expressions
(Daisy Ramirez) #1

Why would a DREF not be recognized?

The field [deal_id] is set as the key in the deals table and I have a field named [amount_type] in the table as well. From my user_deals table, I insert a virtual column and use [deal_id].[amount_type] but the expression builder returns “unable to recognize field amount_type”.

Troubleshoot notes: *In the expression builder I look to connect with another field in the deals table [deal_id].[deal_type] and it was successful. The amount_type and deal_type fields are both ENUM’s and required fields-no variance. *I rename the amount_type field to deal_amount_type and its still not recognized.

Any help would be great! Thanks

(Levent KULAÇOĞLU) #2

@Daisy_Ramirez

Ideally ref/de-ref between Parent and Child tables work like this: # indicates a Key Column

Table1

Table2 #ColunnA.

#Column1 ColumnB

Column2 > ref Table1 ColumnC

Column3

Notice that Table1 is the Parent and Table2 is Child table. Now you can de-ref Table1 (parent) from Table2 (child) like this:

[Column2].[ColumnC]

(Bellave Jayaram) #3

@Daisy_Ramirez did you resolve this issue?

(Daisy Ramirez) #4

@Bellave_Jayaram

Hi Bellave, the issue has not been resolved. As in Levent’s example above the deals table is the parent and the user_deals is the child. I have many dref’s in the app but for some reason this particular one is not being recognized. As mentioned above. I dref’d another column in the deals table (deal_type) and it worked great.