Workflow attachment pdf no longer fits on 1 page

Some time last week we began having an issue where when we print our attachment via eprint it no longer fits on one page. As it has for going on 2 years. The template Doc was not altered. After hours of trying to fix it yesterday I think I have possibly found the culprit. On the bottom of the doc is a signature box that uses the signature image capture in the app. It appears to be making the signature “Image” larger now, thus adding more space to the doc and pushing it past 1 page. I would really like it to go back the way it was, any help would be appreciated. Thanks

It could be potential bug after the PDF generator on the backend was changed, but to test, what is going to happen if you create table with one row / one column and make the border white-out (to make the table invisible) then place your signature column inside of it.
Then you change the size of this table to one that you want.
I assume the table will be controlling the signature image size?
Just as an idea to solve the issue.

1 Like

Hi @KENNETH_HICKS2
Please see this thread

I’ve yet not received a solution from AppSheet.

Maybe this trick will help you also:

Please do also contact support@appsheet.com

2 Likes

Hi @tsuji_koichi you can’t control the image size via table width.
You can only control it via Format Rules.
image
But in my case setting it to “Small” did not change the size of a signature image.
“Tiny” is to small for me.

No you have control over the signature image size with tables.

See this.

The images are coming from the same signature field, and pushed into cell in tables with different number of columns.

4 Likes

I tend to concur with @tsuji_koichi.

There was a similar discussion thread wherein the challenge was with images but the solution was with the width of the table.

4 Likes

Thank you @tsuji_koichi and @Suvrutt_Gurjar for correcting me. In my first testing I was not able to control the image size. Now it worked.
What I saw: You only can control the size via column width, not via column height.
Again: Thank you :slight_smile:

2 Likes

Hi @Fabian ,

You are welcome.

Yes, I believe your observation is correct. Thank you for adding that important point.

@tsuji_koichi may wish to add his insights.

2 Likes

Yes you are welcome @Fabian

As a usual technique, create tables and push the image/signature inside it. And add white to the boarder. and then you would be able to have reasonably free hands to control the sizes.

3 Likes

I do noticed the same issue on my PDF file generated.

I generate invoice which has a space for physical signature, but since yesterday that part is distorted and I have to make changes again in Google Docs.

Besides, the PDF file’s format has been changed as well, my Canon printing app no longer support the PDF file generated by Appsheet. Not sure can anyone help me with this.

Please contact support@appsheet.com for help with this.

@Hong_Yaw_Kuang What’s the file name of the created PDF?
Is the file name or the file type missing?
It should be “AnyFileName.pdf”
Not: “AnyFileName.”
Not: “.pdf”

1 Like

Hi Fabian, the file name is AnyFileName.pdf, it can be open up nicely with every pdf reader, but not Canon print apps which worked for 3 years until last week.


AppSheet has recently changed the method it uses to produce PDF files. Please contact support@appsheet.com for help with this.

3 Likes

Hi @Hong_Yaw_Kuang what PDF Version does your PDF have?

Our printer also does no more printing since it changed from Version 1.4 (Acrobat 5.x) to 1.5 (Acrobat 6.x)

image

image

If we send it directly to the printer the outcome are strange characters.

It will only work if we open it in Adobe and then print it.

Hi Fabian,

I don’t know how to check the PDF version I am using now. Kindly enlighten me :blush: thank you.

Hi @Hong_Yaw_Kuang Please right click on the PDF file and click on “Properties”. In the “Details” pane you can see the version.

1 Like

Hi Fabian, I tried to check the properties on my Mac, but it doesn’t show the version of the PDF file. What if I forward my PDF file to your email?

You can also open the PDF with Adobe Acrobat Reader and in the Menu go to File > Document Properties > Description.

2 Likes